Superuser

Autor Thema: sgi Octane  (Gelesen 6491 mal)

Allfred

  • Gast
sgi Octane
« am: 23. September 2008, 09:11:03 »
Durch Zufall kam ich an eine Octane (CMNB015ANG300)? Immerhin Stecken 2GB Ram im reinen 2x 9GB SCSI System. MIPS-CPU ist ein 300MHz Typ - aber das kann man nicht 1:1 mit einem x86 vergleichen. Da ich mit sowas rein gar keine Erfahrungen habe wollte ich hier mal fragen, welche OS darauf laufen: Bekommt man ein Knoppix zum laufen?

Wie kann ich einen VGA TFT anschließen, der Rechner hat so einen 25pol Sub-D Ausgang mit drei internen HF Buchsen...13W3
Gibts da Adapter auf Standard-VGA?


mood-indigo.org - Das unabhängige Silicon Graphics User Forum

sgi Octane
« am: 23. September 2008, 09:11:03 »

Offline pehy

  • Mood Bachelor
  • ***
  • Beiträge: 239
  • Ich such mir irgendwann 'ne Sig - ganz bestimmt!
    • Profil anzeigen
Re: sgi Octane
« Antwort #1 am: 23. September 2008, 11:17:47 »
Knoppix wird mit Sicherheit nicht drauf laufen, das gibts nur für x86. Ob auf der Octane überhaupt inzwischen ein Linux läuft, weiß ich nicht, und wenn, dann wird es wohl 90% der eingebauten Hardware nicht unterstützen. Die Octane läuft unter Irix, eine Lizenz gehört wohl zur Maschine, Du müßtest Dir also irgendwoher(tm) Installationsmedien borgen und es installieren, falls nicht schon eins drauf ist.

TFT-Monitore kann man anschließen, wenn sie Sync On Green unterstützen (bei mir haben es bisher alle getan), Adapter gibt es bei Reichelt, allerdings sind das Sun-Adapter, die einige Strippen zu viel und an den falschen Anschlüssen haben. Man kann die aber einfach trennen - einfach mal die Suchfunktion hier im Forum benutzen... ;D

Software gibt es bei Nekochan.net und bei sgi (deren Freewaresite wird aber offensichtlich nicht mehr gepflegt). Viel Spaß mit dem grünen Lärmmonster!

Grüße, Peter

Allfred

  • Gast
Re: sgi Octane
« Antwort #2 am: 23. September 2008, 11:55:21 »
Suchfunktion ist schnell gesagt, aber ich fand keine konkrete Umbauanleitung.

Das besagte Reicheltkabel ist unter "AK SUN 5" gelistet, aber hat ab beiden Enden vergossene Stecker. Auch ist es 2m lang und ich müsste mit einem Gender-Changer arbeiten um auf mein VGA Kabel zu kommen...

Sicher gibt es kompakte Adapter - nur wo?

Offline Ten Little Indyans

  • Mood Junior
  • **
  • Beiträge: 82
  • The Indy is an Indigo without the "go".
    • Profil anzeigen
Re: sgi Octane
« Antwort #3 am: 23. September 2008, 15:59:57 »
Sicher gibt es kompakte Adapter - nur wo?

Adapter für den Anschluss an ein vorhandenes VGA-Kabel gibt es z.B. hier:

http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&item=150296853643

oder hier:

http://www.olmos.de/moni.html?lang=de;currency=EUR;tax=no#Monitorkabel_&_Adapter
(MAW3MD15F)

Allfred

  • Gast
Re: sgi Octane
« Antwort #4 am: 24. September 2008, 11:17:20 »
@ Ten Little Indyans: Der verlinkte MAW3MD15F ist wenig kommentiert. Verwendest Du ihn selbst an einem TFT. Ich fürchte, daß es wieder ein SUN Adapter ist. Zumindest kann ich nichts von SGI Pin Assignment lesen.  :-\

Viele verwenden das 'SUN' Kabel von reichelt fuer 8 EUR mit Erfolg. Alle Adapterstecker sind von drittanbietern und hier muss man halt genau aufpassen den das format 13w3 ist nicht nur SGI spezifisch und die gibts dann mit div. PIN Belegungen.

Einen Adapter braucht man immer dann wenn man TFTs hat welche das Kabel fest angeschlossen haben.

Gruss Joerg

Dieser Tipp ist mit 8€ und ein wenig Kabel -gelöte / -gekürze die preiswerteste Lösung. Zumindest liefert Reichelt schneller als eine eBay Bestellung in den Staaten...

mood-indigo.org - Das unabhängige Silicon Graphics User Forum

Re: sgi Octane
« Antwort #4 am: 24. September 2008, 11:17:20 »

Offline pehy

  • Mood Bachelor
  • ***
  • Beiträge: 239
  • Ich such mir irgendwann 'ne Sig - ganz bestimmt!
    • Profil anzeigen
Re: sgi Octane
« Antwort #5 am: 24. September 2008, 16:21:49 »
Die einfachste Lösung für die Reichelt-Kabel ist wegen der angegossenen Stecker, das Kabel im Mittelteil vorsichtig ein paar cm vom Mantel zu befreien und dann alle Strippen, außer den drei Koax-Leitungen für RGB durchzuschneiden und zu isolieren. Die anderen Leitungen sind Luxus. Meine Indigo² und die Octane laufen mit einem so mißhandelten Kabel.

Grüße, Peter

Offline Ten Little Indyans

  • Mood Junior
  • **
  • Beiträge: 82
  • The Indy is an Indigo without the "go".
    • Profil anzeigen
Re: sgi Octane
« Antwort #6 am: 24. September 2008, 21:01:40 »
@ Ten Little Indyans: Der verlinkte MAW3MD15F ist wenig kommentiert. Verwendest Du ihn selbst an einem TFT. Ich fürchte, daß es wieder ein SUN Adapter ist. Zumindest kann ich nichts von SGI Pin Assignment lesen.  :-\

Nein, diesen konkreten Adapter kenne ich sonst nicht näher. Bei OLMOS habe ich vor ca. elf Jahren meinen original SGI GDM-20D10 Monitor gekauft. Die handeln sowohl mit Sun- als auch mit SGI-Teilen, so dass ich davon ausgehe dass sie Bescheid wissen. ::) Wenn man einen solchen Adapter "für SGI" bestellt sollte es passen, ansonsten gibt es ja ein Rückgaberecht...

Mit den Reichelt-Kabeln habe ich sehr durchwachsene Erfahrungen gemacht. An SGI Indy und Indigo² war das Verhalten nie klar reproduzierbar. Mal kam ein Bild, mal nicht. Das hat mich damals fast in den Wahnsinn getrieben. An meinen Sun SPARCstations funktionierten die Kabel übehaupt nicht. Laut Datenblatt war die Belegung auch völlig falsch für Sun (Stand Ende 2003). Bei einem Kabel habe ich dann sämtliche Pins ausser den drei Mini-Coax abgekniffen, seitdem läuft meine Indy damit an einem Sony TFT.

Viel bessere Erfahrungen habe ich mit einem 13W3-auf-DVI-A-Kabel gemacht welches vor einigen Monaten bei eBay.de zu haben war. Damit funktionierten alle meine Systeme mit 13W3 auf Anhieb. (SGI Indy XL / Indigo² XZ + Impact, Sun TGX / SX / Creator3D / Elite3D und IBM GXT150).

töfte

  • Gast
Re: sgi Octane
« Antwort #7 am: 25. September 2008, 18:57:58 »
Das 13w3-auf-vga-Problem ist ein leidiges und eine Patentlösung kennt dafür auch keiner.

Ich habe eine grüne Octane mit Impact-basierender Graphikkarte und eine blaue mit VPRO-Karte. Dazu habe ich ein komplettes (also vorkonfektioniertes) SGI-Wandlerkabel und ein normales VGA-Kabel + einen 13W3-VGA-Adapter.
Ergebnis: blau  läuft mit vorkonfektioniertem Kabel, grün läuft damit nicht. Genauer gesagt: mein Monitor lief damit nicht; er zeigte eine gewünschte Wiederholfrequenz von 388 Hz an  und eine Meldung irgendwas mit out of Range .
Grün lief auch mit dem dem Adapternicht, also kniff ich alle Kontakte bis auf die RGB-Kontakte ab, dann lief grün mit dem Adapter + VGA-Kabel.
Blau läuft auch mit Adapter und VGA-Kabel.
Allerdings ist dies die einzige Kombination die definitiv auch gehen muß, da alle mir bekannten SGI-Graphikkarten sync auf grün erkennen und richtig darstellen.
So, was kann man daraus schließen ? SGI-Kabel sind nicht immer SGI-konform und VPRO ist weniger zickig mit den Anschlußbelegungen  :o :)

« Letzte Änderung: 25. September 2008, 19:04:09 von töfte »