Superuser

Autor Thema: Schon bemerkt? Neue Forums-URLs...  (Gelesen 3997 mal)

Offline Jerry

  • Mood Administrator
  • Mood Master
  • *****
  • Beiträge: 283
  • Never beige ;-)
    • Profil anzeigen
    • mood-indigo.org - Das SGI Heimanwender Forum
Schon bemerkt? Neue Forums-URLs...
« am: 06. September 2007, 22:08:48 »
Vielleicht ist es Euch bei dem gelegentlichen "Flackern" des Forums heute nachmittag schon aufgefallen - ich habe ein neues SMF-Modul installiert, das "sprechende" URLs baut. Die Dinger werden dadurch zwar länger, sollten aber wegen der Post-Titel ein besseres Suchmaschinenranking und damit bessere Auffindbarkeit von Themen bringen.

Ganz nebenbei erreiche ich was, was ich immer schon wollte - endlich sehe ich in den Statistiken des Webalizers mal, welche Themen wie intensiv besucht werden. Die Statistik des SMF wirft da zu wenig aus, und die alten URLs enthielten ein "index.php", was den lieben webalizer veranlasst, alles in einen Topf zu schmeissen ("Riecht wie index-Seite, heißt wie index-Seite, ist index-Seite").

Die alten URLs sollten - da der ganze Spaß mit mod_rewrite gelöst ist - transparent funktionieren. Sollten heißt, es kann auch schiefgehen, drum bitte ich Euch, mich darauf hinzuweisen wenn etwas nicht so tut, wie es Eurer Auffassung nach sollte. Den schwerwiegendsten "Bug" dieser Art hatte ich selbst schon bemerkt, denn die Erweiterung hat den Editor, den ich für die Artikelverwaltung nutze, in die Knie geschossen. Zwei weitere RewriteRules haben das dann aber behoben (war bloß ein Akt, drauf zu kommen - daher auch das elende "Flackern" mit mal neuen und mal alten URLs heute...)

Dachte ich erzähl's mal ;)

Jerry
 
Sure vi is user-friendly; it's just peculiar about who it makes friends with.

mood-indigo.org - Das unabhängige Silicon Graphics User Forum

Schon bemerkt? Neue Forums-URLs...
« am: 06. September 2007, 22:08:48 »

jobeh

  • Gast
Re: Schon bemerkt? Neue Forums-URLs...
« Antwort #1 am: 07. September 2007, 12:21:54 »
Noch nicht so ganz denn die URLs sehen nun so aus
http://www.mood-indigo.org/empty-t4399.0.html;topicseen

ich gehe mal davon aus das anstelle des "empty" die Bezeichnung des Threads stehen sollte oder?

Ah, ich sehe das es doch schon funktioniert... nur nicht wenn man von der Seite "Zeige ungelesene..." kommt.

Gruss
Joerg