Superuser

Autor Thema: YaBB Bugs  (Gelesen 7632 mal)

SmellyCat

  • Gast
YaBB Bugs
« am: 26. März 2004, 12:30:53 »
Hallo,

Euch ist sicher schon aufgefallen dass dann und wann Bugs Eure Postings etwas deformatieren ;) Ich kenne ein paar Tricks (wer bessere kennt darf sie gerne beisteuern) wie man fast alle diese "Patzer" beheben kann, fangen wir an:

[ = (



Er erste Fall wäre der http://URL Tag, dieser hier (url)(/url)
Er kann zwei Fehler produzieren. Der erste ist dass der nachfolgende Text wie nachfolgende Links zu dem Link hinzu addiert werden, sprich der Text nach dem Tag als Link gilt und dem entsprechend aussieht.

Man sucht sich den entsprechenden Bösewicht raus und setzt ein "(url).(/url)" direkt ohne Leerzeichen dahinter. Der "." fällt nicht weiter auf, verhindert aber dass sich der Link "ausbreitet" und den restlichen Text assimiliert. Dieser URL Tag weißt dann auf das Forum da er aber kam sichtbar ist wird ihn auch keiner anklicken, sieht so aus: -> http://. <-

Dieser Trick hilft auch wenn YaBB nach einem Link Bold weiterschreibt, womit wir beim nächsten wären:



Ungewollte Fettschrift:
Die Ursache ist meist ein falsch interpretierter HTML Tag, nämlich <br>. Wenn aus einem nicht ganz ersichtlichen Grund auf einmal der Text fett ist kann das die Ursache sein, Lösung ist banal: einmal Enter vor der Zeile in der die Fett-Schrift beginnt, dann erscheint der Tag <br> zwar im Text hat aber keine Auswirkungen mehr auf dessen Formatierung. Hilft das nichts, 2x Enter oder (b).(/b) vor die fragliche Stelle setzen.



Der bösartigste Bug ist der in der (quote)(/quote) Funktion. Er hat zur Auswirkung dass entweder der nachfolgende Text sich über die gesamte Seite erstreckt oder alles nachfolgende schwarz wird. Man kann in 99% der Fälle Abhilfe schaffen in den man den abschließenden (/quote) eine oder 2 Zeilen nach unten rückt, also statt:
(quote)blah(/quote)

(quote)blah
(/quote)

oder
(quote)
blah
(/quote)

schreiben. Manchmal bringt YaBB auch ein Bild oder ein Smile ( :) ) durcheinander, dann hilft nur das aus dem zitierten Text rauszuwerfen. Auch andere Steuer Tags im zitierten Text können solche Auswirkungen haben, also Italic oder Bold, einfach probieren auch diese rauszuwerfen.
Ich habe aber auch schon ein paar mal erlebt dass dieser Bug einfach nicht zu kompensieren ist, dann hilft nur noch statt (quote) eben (i) zu nutzen.



Ach ja - wichtig bei URLs etc immer die YaBB Tags nutzen, bei einer URL im Text kapiert es YaBB stellenweise auch ohne ab zwei URLs ohne Tag bekommt es Schluckauf ;)

bye
Mats

mood-indigo.org - Das unabhängige Silicon Graphics User Forum

YaBB Bugs
« am: 26. März 2004, 12:30:53 »