Autor Thema: Problem beim ImageMagick kompilieren  (Gelesen 2911 mal)

tom_bones_melone

  • Gast
Problem beim ImageMagick kompilieren
« am: 25. Juni 2003, 17:43:10 »
Werte Herren,

ich stehe wieder mal vor einem Problem. Ich möchte Imagemagick kompilieren und ./configure gibt folgendes aus:

configuring ImageMagick 5.5.6
checking build system type... mips-sgi-irix6.5
checking host system type... mips-sgi-irix6.5
checking target system type... mips-sgi-irix6.5
checking whether build environment is sane... yes
checking for a BSD-compatible install... ./install-sh -c
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.

Das mache ich dann auch und da steht an der entsprechenden Stelle:

...
...
configure:2379: $? = 0
configure:2381: gcc -V </dev/null >&5
gcc: argument to `-V' is missing
configure:2384: $? = 1
configure:2408: checking for C compiler default output
configure:2411: gcc    conftest.c  >&5
/opt/MIPSpro/bin/ld[123]: /usr/bin/ld:  not found
collect2: ld returned 127 exit status
configure:2414: $? = 1
configure: failed program was:
| #line 2387 "configure"
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2452: error: C compiler cannot create executables
See `config.log' for more details.
...
...


Was will mir mein Rechner sagen?

Ratlos
Christian


mood-indigo.org - Das unabhängige Silicon Graphics User Forum

Problem beim ImageMagick kompilieren
« am: 25. Juni 2003, 17:43:10 »

KaeptnF

  • Gast
Re: Problem beim ImageMagick kompilieren
« Antwort #1 am: 25. Juni 2003, 17:51:20 »
Hallo!

Hast Du die "IDO" und die "Development Libs" installiert?

Normalerweise kommt dieser Fehler, wenn er versucht mit dem "gcc" zu linken und den nativen Linker nicht findet, denn der muß da sein, da der "gcc" von "freeware.sgi.com" mindestens seit Version 2.95.2 keinen eigenen Linker mehr mitbringt.

Nachträglich hinzugefügt:
Und jetzt habe ich es auch in der Ausgabe gesehen: Dein Linker fehlt. Also die beiden o.a. Dinge installieren!

Beste Grüße,
Faber.
« Letzte Änderung: 25. Juni 2003, 17:54:25 von KaeptnF »