Autor Thema: Nun ist's mir auch passiert...  (Gelesen 13271 mal)

pehy

  • Gast
Nun ist's mir auch passiert...
« am: 15. September 2014, 21:46:59 »
...das Netzteil meiner Octane ist nach ca. zwei Stunden Dauerbetrieb gestern hochgegangen. Die Maschine ging aus, das Netzteil schaltete sich noch zweimal kurz alleine ein, bevor ich endlich auf die Idee kam, die Steckdosenleiste auszuschalten. Danach roch es nach Strom. Eher hoffnungslos habe ich auf der Elektrobucht einen entsprechenden Suchbegriff eingegeben und tatsächlich passende Netzteile entdeckt! Ich warte jetzt auf den Postboten, hoffentlich hat's nicht irgendwas im Rechner zerschossen! ::)
Diesmal ist es gleich ein Octane2 - Netzteil, das originale war -ähm- eben original.  ;D

Nachdem ich mich dann mit der Indigo² trösten wollte, kam deren Festplatte (gewaltige 6,x GB groß) nur nach mehreren Versuchen in Gang. Ich glaube ich muß den beiden Schätzchen ein wenig mehr Aufmerksamkeit schenken. Was baut man denn am besten in eine Indigo² als Festplattenersatz ein, SCA-Platte plus Adapter zum Beispiel?

Grüße, Peter

(hoffend, daß hier noch jemand liest)

mood-indigo.org - Das unabhängige Silicon Graphics User Forum

Nun ist's mir auch passiert...
« am: 15. September 2014, 21:46:59 »

Offline Ebbi

  • Mood Administrator
  • Mood Master
  • *****
  • Beiträge: 359
  • Ubergeek
    • Profil anzeigen
Re: Nun ist's mir auch passiert...
« Antwort #1 am: 16. September 2014, 08:09:27 »
Was baut man denn am besten in eine Indigo² als Festplattenersatz ein, SCA-Platte plus Adapter zum Beispiel?
Ja, das bietet sich an.
Allerdings sollte man bei den Platten ein Händchen bei der Auswahl haben.
Denn die neueren 10.000 rpm Platten können ziemlich heiß werden und das ist ohne Kühlung auf Dauer nichts.

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #2 am: 18. September 2014, 00:34:58 »
Neuer Stand: Netzteil kam heute an. Habe es eingebaut, Netz angeschlossen - es klickt im Netzteil. Einschalter gedrückt, leider keinerlei Reaktion. Es ist also noch was anderes kaputt.  :-[

Also "Mainboard" rausgebaut. Die optische Inspektion ergibt nichts auffälliges, es riecht auch nicht verbrannt. Danach die SI-Grafik mit TRam rausgeschraubt, gleiches Ergebnis. Frontverkleidung abgenommen, jetzt riecht es etwas "elektrisch"! Die Festplatte ist es aber nicht, also wird's wohl die "Frontplatte" mit der Crossbar drauf erlegt haben. Da kommt der Geruch her. Mal sehen, ob ich mir die Komplettzerlegung des Eisenmonsters antue, nur um das zu bestätigen. Eine neue Trägerplatine brauche ich dann ja auch noch und es ist nicht sicher, daß die bisher optisch und olfaktorisch als OK eingeschätzten Karten tatsächlich in Ordnung sind. Allzuviel Geld werde ich dafür nicht mehr ausgeben, dann vielleicht doch lieber entweder preiswert eine funktionierende Octane besorgen oder mit der hoffentlich bald wieder laufenden Indigo² Vorlieb nehmen, die ich dann neu mit Irix versorgen muß. Hat mal wer ein Image der Irix 6.5 Development Foundation? Meine ist nämlich nicht mehr lesbar, wie ich gestern festgestellt habe. Von den anderen beiden Foundation-CD's und dem Rest des CD-Satzes habe ich jetzt Images gesichert.

Frühmorgentliche Grüße, Peter

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #3 am: 28. September 2014, 20:27:30 »
Aktueller Stand:

Ich habe die Octane komplett zerlegt, keinerlei Brandspuern, alles sieht OK aus. Nur einschalten lässt sie sich nach wie vor nicht. Ich habe versucht, sie ohne Grafikkarte und ohne "Mainboard" und auch ohne beides einzuschalten - alles ohne Erfolg. Vermutlich ist tatsächlich die Frontplane irgendwie hinüber...

Nächste Woche nehme ich die Indigo² mit einer neuen alten SCA-Platte mit Adapter in Betrieb. Dabei ist mir aufgefallen, daß der Stecker am Festplatten-Träger einem SCA-Anschluß sehr ähnlich sieht. Könnte man da direkt eine SCA-Platte anschliessen?

Peter

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #4 am: 09. Oktober 2014, 14:48:29 »
Die Indigo² läuft noch nicht mit der neuen alten SCA-Platte am Adapter auf SCSI 50-polig. Die Platte taucht in der nach "hinv" ausgegebenen Liste nicht auf. Ich probiere derzeit mit den Jumpersettings umher.

Peter

Offline foetz

  • Mood Bachelor
  • ***
  • Beiträge: 118
    • Profil anzeigen
    • R-A-C
Re: Nun ist's mir auch passiert...
« Antwort #5 am: 10. Oktober 2014, 09:10:28 »
Die Indigo² läuft noch nicht mit der neuen alten SCA-Platte am Adapter auf SCSI 50-polig. Die Platte taucht in der nach "hinv" ausgegebenen Liste nicht auf. Ich probiere derzeit mit den Jumpersettings umher.

Peter
ja, das alte problem. auch wenn die platte mechanisch passt muss sie nicht unbedingt mit der indigo2 laufen. die platte muss single ended scsi unterstuetzen. manchen neueren modellen fehlt das

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #6 am: 11. Oktober 2014, 23:08:55 »
Die Platte ist eine IC35L146UCDY10-0 80P ULTRA320 SCSI DRIVE für IBM von Hitachi produziert.

Der "force SE" - Jumper auf der Platte ist gesteckt, alle anderen sind offen, Die SCSI-ID habe ich auf dem SCA-50pol.-Adapter auf 1 eingestellt. Eigentlich sollte das so laufen, tut es aber nicht. Auf der Platte selber gäbe es (neben der SCSI-ID) noch folgende Jumper zur Auswahl: DISABLE UNIT ATTN, TI SYNC NEGO, DISABLE PARITY, DELAY START 6/12, AUTO START DELAY und DISABLE AUTO SPIN

Peter

proxima

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #7 am: 06. November 2014, 21:05:47 »
Die specs sagen da folgendes:

http://www.hgst.com/tech/techlib.nsf/techdocs/6BB69573F9D1537687256BD600697AAA/$file/u146z10_sp22.pdf

Page 39:
NOTE: SCA-2 connector is not mechanically compatible with the 68 pin “P” connector as defined in the
ANSI SCSI standard. The connector is intended for direct back plane attachment and is not intended to
be cable attached to the bus.

Page 40:
Terminator power
Termination power can be provided by the drive 5V supply through the current limiter and Schottky diode.
This function can be selected by jumper.
The 80-pin SCA-2 models do not support SCSI bus termination power.

Ich versteh das so, das deine Platte keine Terminierung hat. Deswegen läuft sie wohl auch nich...

Edit: thx tenlittle, hab den link korrigiert. is wohl beim c&p mit durchgerutscht  ;)
« Letzte Änderung: 09. November 2014, 15:15:52 von proxima »

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #8 am: 06. November 2014, 23:08:59 »
Die specs sagen da folgendes:

http://www.hgst.com/tech/techlib.nsf/techdocs/6BB69573F9D1537687256BD600697AAA/$fileu146z10_sp22.pdf
Bei mir kommt da nur die Auswahlseite und dann bei beiden pdf's ein 404. Morgen nochmal probieren...
Zitat
Page 39:
NOTE: SCA-2 connector is not mechanically compatible with the 68 pin “P” connector as defined in the
ANSI SCSI standard. The connector is intended for direct back plane attachment and is not intended to
be cable attached to the bus.
Sie steckt ja auch direkt auf dem SCA -> 50pin-SCSI-Adapter, damit dürfte das eigentlich nicht das Problem sein.
Zitat
Page 40:
Terminator power
Termination power can be provided by the drive 5V supply through the current limiter and Schottky diode.
This function can be selected by jumper.
The 80-pin SCA-2 models do not support SCSI bus termination power.

Ich versteh das so, das deine Platte keine Terminierung hat. Deswegen läuft sie wohl auch nich...
Das könnte allerdings sein, ich forsche mal nach. Inzwischen habe ich so ein Teil http://www.codesrc.com/mediawiki/index.php?title=SCSI2SD bestellt. Wenn's nicht klappt, bekommt mein Amiga4000T endlich eine leise und sparsame Festplatte. ;D

Peter

Offline Ten Little Indyans

  • Mood Junior
  • **
  • Beiträge: 81
  • The Indy is an Indigo without the "go".
    • Profil anzeigen
Re: Nun ist's mir auch passiert...
« Antwort #9 am: 07. November 2014, 14:17:23 »
Beim Link fehlte ein '/' nach $file:

http://www.hgst.com/tech/techlib.nsf/techdocs/6BB69573F9D1537687256BD600697AAA/$file/u146z10_sp22.pdf

Das SCA-2 (80 pin) nicht kompatibel zu einem normalen 68 pin Wide-Anschluss ist sollte klar sein.  Die Indigo2 verwendet aber (angeblich(*)) SCA-2 um die Laufwerksschlitten an die Backplane anzubinden.

http://forums.nekochan.net/viewtopic.php?f=3&t=16728787#p7370289

Elektrisch sollte man also eine SCA-Platte direkt ohne Schlitten anschliessen können, mechanisch passt es aber wohl nicht richtig.

(*) Hab kein Hardware Developer Handbook greifbar um diese Aussage überprüfen zu können.

Termination Power ist noch etwas anderes als die eigentliche Terminierung, welche dieses Laufwerk gar nicht bietet (siehe Spec, 7.1.4).  Bei Systemen die eine Backplane verwenden ist der SCSI-Bus üblicherweise hinter dem letzten Anschluss auf der Platine terminiert.  Die eingesteckten Laufwerke sind dann natürlich alle ohne Terminierung.

Inzwischen habe ich so ein Teil http://www.codesrc.com/mediawiki/index.php?title=SCSI2SD bestellt.
Genial!  Das brauche ich auch. Mehrfach.

Ein "SCSI-Simulator" auf Raspberry Pi-Basis wäre auch mal eine nette Idee, sofern dafür genug GPIO-Pins zur Verfügung stehen.  Also das Protokoll komplett in Software nachbilden.  So könnte man die Simulation perfekt an die jeweiligen Eigenheiten des Host-Rechners anpassen.

proxima

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #10 am: 09. November 2014, 15:37:19 »
Solche Adapter sind ja ganz nett, um die alten Kisten weiter am Leben zu halten, aber die Preise sind jenseits von Gut & Böse  :o . Aber brauchen könnte ich solche Teile auch... SCSI zu SATA wär auch interessant

Ob der RasPi allerdings die Timings halten kann beim Transfer auf dem Bus, halte ich für ziemlich fraglich, zumal beim Pi ja nur USB und SD zur Verfügung stehen. Und USB is nich für RealTime bekannt  ;D Und ne SD hält nich ewig,was Schreibzugriffe betrifft.


Offline Ten Little Indyans

  • Mood Junior
  • **
  • Beiträge: 81
  • The Indy is an Indigo without the "go".
    • Profil anzeigen
Re: Nun ist's mir auch passiert...
« Antwort #11 am: 14. November 2014, 10:20:55 »
Ja, der Preis für ein SCSI2SD ist schon heftig.  Dank Open Source kann man sich so ein Teil auch selbst zusammenbauen, was aber mit Platine und allem wohl auch nicht so viel günstiger werden dürfte.

Ich spiele schon seit Jahren mit dem Gedanken mir ein paar SCSI-IDE Adapter zu besorgen, aber die kosten noch ein paar Scheine mehr.  SCSI-SATA gibt es von ACARD auch, z.B. ARS-2320S oder AEC-7732U (wohl nur für optische Laufwerke?) aber da ist man schon im Bereich um 200 Euro...

Bei einem Pi "SCSI-Simulator" würde ich mich erstmal auf das ursprüngliche SCSI-1 (5MB/s) beschränken wollen.  Ziel wäre es nämlich entsprechend alte Festplatten zu simulieren wie sie z.B. von einer IRIS 4D, Sun-3 oder VAXstation erwartet werden.  Die halten heute noch weniger ewig als eine SD-Karte deren Image man jederzeit auf eine neue Karte kopieren kann.
« Letzte Änderung: 14. November 2014, 14:11:49 von Ten Little Indyans »

proxima

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #12 am: 17. November 2014, 14:46:50 »
 Also i-wie haste mich mit deinem SCSI Pi angezeckt ;) und ich hab da mal drüber gegrübelt. Es gibt SCSI2USB adapter (z.b. von ratoc). Normalerweise sollte es dem Wandlerchip in dem Ding egal sein, in welche Richtung der das Protokoll übersetzt. Also "könnte" (ich würd das ganze am liebsten nur im Konjunktiv schreiben...) das auch an den SCSI Bus geklemmt funktionieren. Allerdings seh ich immernoch mehrere Probleme:

* der SCSI2USB Adapter muss am Pi laufen und lässt den gesamten SCSI-Befehlssatz transparent durch (muss also als normales device angesprochen werden können)
* auf dem Pi läuft ein extrem schlankes Linux, damit der Pi hinterherkommt. (Du willst ja software-emulation machen)

Die 2.te Variante ist die, das man nen SCSI2USB Adapter findet,der das alles selber kann  ;D Also ran an den SCSI-Bus, USB Platte dranne, fertich...
Für Google bin ich grad zu breit, frisch aus dem Hospital entlassen...

pehy

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #13 am: 17. November 2014, 18:19:23 »
Solche Adapter sind ja ganz nett, um die alten Kisten weiter am Leben zu halten, aber die Preise sind jenseits von Gut & Böse  :o . Aber brauchen könnte ich solche Teile auch... SCSI zu SATA wär auch interessant

Ob der RasPi allerdings die Timings halten kann beim Transfer auf dem Bus, halte ich für ziemlich fraglich, zumal beim Pi ja nur USB und SD zur Verfügung stehen. Und USB is nich für RealTime bekannt  ;D Und ne SD hält nich ewig,was Schreibzugriffe betrifft.
Wenn man das hardcore will, könnte man ja die SCSI-Seite über GPIO-Pins nach draussen bringen. Ob das in Echtzeit geht, kann ich aber nicht beurteilen.

Mein SCSI2SD liegt seit Freitag beim Zoll, weil der Versender draussen nichts drangeklebt hat.   :-\ Morgen fahre ich hin und versuche das da loszueisen.

Peter

proxima

  • Gast
Re: Nun ist's mir auch passiert...
« Antwort #14 am: 11. Januar 2015, 23:43:43 »
schreib doch mal deine erfahrung, wie das mit deinem scis2sd so geworden ist...  ;)